Technicolor TG784n v3 – Configurações via telnet

router-Technicolor TG784n-v3Neste artigo vou descrever algumas configurações que podem ser interessantes para quem utiliza o router Technicolor TG784n v3.

Claro que depende das necessidades de cada um, mas vou descrever neste artigo a modificações que fiz no meu router. Bem como configurações que me sejam sugeridas.

As configurações vão ser feitas pela linha de comandos utilizado o comando telnet, que pode ser encontrado em qualquer sistema operativo.

Para tal utilizamos o comando “telnet 192.168.1.254” para nos ligarmos ao router. Caso tenham mudado o IP do vosso router façam as modificações apropriadas.

Ora vamos lá! A partir deste momento assumo que estamos ligados e autenticados via telnet ao router. Devem autenticar-se com um utilizador do tipo “RootUser” Como o utilizador “supermeo” que criei no artigo anterior.

Uma coisa importante para mim, logo de inicio foi configurar o timeout do telnet, que por defeito é de 600 segundos como podemos confirmar com o seguinte comando:

env get var=SESSIONTIMEOUT

Como eu gosto de ter por vezes a ligação ao router por um tempo indeterminado é importante para mim remover este timeout. Para remover este timeout corremos o seguinte comando:

env set var=SESSIONTIMEOUT value=0

Para que esta configuração sobreviva a um reboot temos de guarda-la e para isso usamos o comando:

saveall

O comando saveall serve como o próprio nome diz para guardar todas as modificações feitas no router. Portanto a partir deste momento sempre que fizermos uma modificação que queiramos tornar permanente corremos o comando saveall para esse efeito.

Reiniciar o router

Quando queremos reiniciar o router podemos lançar via telnet o comando:

system reboot

Através da linha de comandos é mais rápido reiniciar o router. Só temos que nos ligar e escrever este pequeno comando.

Mudar a palavra passe

Para mudar a palavra passe de um utilizador corremos o seguinte comando:

user config name=supermeo password=123456789

Neste caso vou mudar a palavra passe do utilizador supermeo para 123456789. Não utilizem uma palavra passe assim tão simples claro. O utilizador pode ser qualquer um existente no sistema. Com excepção do utilizador “nauser” e “CP1344RAA6K” que não aceita. Aconselho a mudarem a palavra passe de todos os utilizadores.

Listar os utilizadores

Para listarem os utilizadores do vosso router usem o seguinte comando:

user list

Desabilitar acesso remoto pelo ISP

Para desabilitar o acesso remoto do vosso ISP ao vosso router corram o seguinte comando:

service system modify name=CWMP-S state=disabled

Claro que depois disto o vosso ISP não vos poderá dar assistência remota, a não ser que mudem o state=disabled para state=enabled. É importante desactivar este serviço para evitar que entrem no vosso router sem o vosso consentimento, bem como para poupar recursos do router.

Desabilitar portas ethernet

Caso queiramos desactivar  portas ethernet que não estejam em utilização podemos fazê-lo, para isso corremos o seguinte comando:

eth device ifconfig intf=ethif1 state=disabled

Neste caso desactiva a primeira porta do switch ethif1, caso queiramos listar  as portas existentes corremos o seguinte comando:

eth device iflist

Para activar alguma porta que tenhamos desactivado anteriormente, corremos o seguinte comando:

eth device ifconfig intf=ethif1 state=enabled

Neste caso activa a primeira porta do switch ethif1. Desabilitando tudo o que não utilizamos vai nos permitir ficar com alguns recursos para aquilo que realmente usamos.

 Listar os dispositivos conectados

Se por alguma razão necessitarmos de saber quais os dispositivos que estão conectados ao router, corremos o seguinte comando:

hostmgr list

Isto pode ser bastante importante em locais menos seguros em que podem usar o nosso router sem nossa permissão.

Ligar e desligar os leds

Bem para quem for como eu, que gosta de ter os leds do router sempre ligados para de vez em quanto dar uma olhada na actividade dos leds, então é possível. Para que os leds permaneçam sempre ligados corremos o seguinte comando:

led config enableLEDinfo=yes

Se preferirmos que os leds se permaneçam apagados corremos o seguinte comando:

led config enableLEDinfo=no

De momento é tudo, mas vou continuar a actualizar este artigo com configurações que podem ser úteis.

Para quem gosta ou necessita ler o manual deste router pode descarrega-lo nos anexos do artigo.

Para os mais aventureiros criei um script para ajudar a automatizar comandos repetitivos, é um script em PHP, necessitam ter o php-cli instalado no vosso Linux. Encontra-se nos anexos. Tem alguma ajuda em português, que penso ser suficiente para poderem elaborar e automatizar comandos mais complexos.

Deixem-me saber aquilo que gostavam de saber que talvez vos poderei ajudar a encontrar uma solução.

Comentem, Partilhem e Experimentem!

Artigos Relacionados:

19 comentários sobre “Technicolor TG784n v3 – Configurações via telnet

  1. Diogosays:

    Olá,
    Eu sou portador do rooter Technicolor TG784n v3 e entrei pelo mesmo via internet,de seguida, agora nem sei muito bem porque, mas eu decidi dar-lhe reset e po-lo com as definiçoes padrao ,o que é certo que a partir dai nunca mais tive a net que tinha , antes via videos a 1080p 60fps e agora so consigo ver a 480p com bastantes paragens, antes jogava com um pinn de 39,agora passa dos 120, o que é certo e notório é que dar reset ao rooter fez com que o rendimento da internet desce-se ridiculamente .
    Agradecia que pudesse ajudar, Obrigado
    cumprimentos de,

    Diogo Marques

    • Olá Diogo,
      Penso que não seja por fazer reset ao router que tenha perdido qualidade na ligação. E se realmente é verdadeiro, será por algum tempo até ser auto configurado. Os router são preparados para isso mesmo, essa é uma das razões que leva a MEO a bloquear certas partes do router para que o cliente não tenha acesso a certos dados.

      Quanto ao ping é certo que a rede da MEO tem uma latência alta o que para os jogadores e não só é mau.
      Eu neste preciso momento tenho estas condições:

      Hosted by MEO (Lisbon) [17.11 km]: 105.141 ms
      Testing download speed........................................
      Download: 83.13 Mbit/s
      Testing upload speed..................................................
      Upload: 19.49 Mbit/s

      No entanto acho que deveria expor isto mesmo à MEO.

  2. Rodrigo Miguel Marquessays:

    Boas, gostaria de saber se é possivel alterar o IP da partilha de conteudos (contentsharing), pois o meu router ja nao está na rede 192.168.1.0, mas sim na 192.168.0.0, e o router decidiu que o novo ip de partilha de conteudo é o 192.168.0.41, e este nao da para alterar na web-interface

    Cumps.

  3. Franciscosays:

    Artigo muito interessante e informativo. Parabéns.
    Será possível também desligar os serviços de FTP, TELNET, SSH e PPTP que estão ativos por defeito neste router (em dsldevice.lan)?

    Obrigado!
    versão do firmware é 10.2.1.O

  4. z.e.antonioramos@hotmail.comsays:

    Gostaria se me poderia ajudar tenho techicolor tg784 n v3 serviço fibra vodafone tinha antes de renovar por wi fi 65mbs em qualquer canal renovei para 100mbs por cabo mas por wi fi continua nos 65mbs será que não há uma solução para emitir mais sinal wi fi?

  5. Joao Portugalsays:

    Olá.

    Antes de mais, obrigado por estes tutoriais com comandos para o router MEO.

    Segui alguns comandos daqui deste tutorial e consegui sempre com sucesso que os mesmos corressem bem.

    Entretanto estou com um problema no comando de “Ligar e desligar os leds” onde eu coloco o comando “system qual led value=unlock” para que os leds do TG784N v3 fiquem sempre acessos sem ser necessário andar sempre a carregar no botão i do router, e mesmo depois de executar o comando e fazer “saveall” e reiniciar o router, os leds após o router reiniciar passados uns segundo voltam a apagar e só são visíveis voltando a carregar no botão i e passados uns segundos voltam todos a apagar.

    No Apoio técnico MEO, dizem que este router não dá para manter os leds sempre acessos, pois é um router ECO que é para economizar electricidade, enfim.

    Alguma solução ou algo mais que se possa fazer ou estarei a fazer algo errado?

    Tenho Root do router.

    Ou será que após executar este comando, na parte do Wireless que não uso e tenho desligado, renho que retirar também o visto de poupança de electricidade?

    Obrigado.

    • Olá joão,

      verdade que tenho várias modificações para se adequar às minhas necessidades.

      Quanto às opções de poupança de energia as minhas são seguintes:

      eco-manager=disabled // utilizo para desabilitar as funções de gestão de energia
      cpu-microsleep=disabled // não pretendo que o cpu adormeça
      cpu-lowspeed=disabled // quero que o cpu responda ao máximo speed
      usb-controller=disabled // não uso desabilitei
      wlan-pwrcontrol=disabled // não uso desabilitei

      Para desabilitar o modo eco, utiliza o seguinte comando via telnet:

      pwr config eco-manager=disabled
      saveall

      Eu testei no meu e não tem influencia com os leds eu uso a versão 10.2.1.D.

      De qualquer maneira, experimenta desabilitar o modo eco e se poderes diz como correu e se tem alguma influencia.

  6. Joaquim Emílio São Pedrosays:

    Sou possuidor de um router THOMSON TG784 da MEO, que não consigo fazer o login, introduzindo o nome de utilizador e a password que o instalador do serviço me deixou aqui inscrita num papel.
    Já fiz tudo e mais alguma coisa, em termos de opinião recolhida em diversos fóruns, nomeadamente, nesta página, e o que é certo, não obtive ainda resultados.
    Não consigo aceder ás configurações e, como tal, não consigo estabelecer a ligação a um NAS que adquiri, para armazenamento de dados.
    Alguém me pode ajudar a resolver o problema.

  7. Nunosays:

    Tenho uns problemas de quebras constantes no Meo. O técnico disse que provavelmente é o router. Diz ele que o router tem um buffer que lota e provoca as quebras, nomeadamente se usar um Mac, que é o meu computador. Tenho ampla experiência em informática, mas não sei até que ponto isso é verdade. Disse ele que o suporte acedeu remotamente o router e instalou uns scripts que irão resolver isso. Queria saber até que ponto isso é verdade e, se for, se existe maneira de limpar esse buffer.

    Outra coisa é, no caso desse router ser o problema, vale a pena comprar um router mais poderoso no mercado por minha conta?

Deixe uma resposta